Custom Fields visibility frustrations in Custom Item Types

The visibility of Custom Fields under the "More Fields" dropdown in the side panel of an item is frustrating.  If I create a Custom Item Type with no fields visible in the side panel, I would expect that none show up, but that is not the case and I don't understand why?

So here I have a Custom Item type with just three fields in the top area, and nothing in the side menu

When I create a task from this item type, there is nothing in the side pain, but the More fields button is there and can be expanded to show all the fields that are in the space.

Why?  This just seems messy and confusing.  If I don't put the fields in the Custom Item Type, then I don't need them in that type of task.  They should not be there.

Upvote 6
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos
4 comments

I have pondered this same question and agree with Russell's suggestion.

1
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Hi Russel

What I've found out so far. The custom fields listed under "More fields" are additionally driven by table views. So any custom item type that is part of that table will have that field listed under "More fields". Since it is part of that table view, it is likely that you will be able to populate that field, which will then need to be available and stored somewhere in the item type. That's probably the logic behind it.

You can get rid of this by removing the custom field from that table. (Only if the other item types don't also use it.) You can go to your space settings -> custom fields -> select the field you want to remove from a folder or project -> remove from.

 

1
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Thanks Jonathan
That makes some sense for the tables that the custom item type is in, but as you can see this table doesn't have any extra fields
It is a real inconvenience to have to go into the space custom fields and remove or add to specific folders/projects.  It is my solution for now, but I really feel like the fields should follow what is set in the custom item type regardless of what is shared with the space or set in the table.

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Hi Russell Sprague, thank you for creating this post! Our Product Team is currently exploring alternatives to optionally hide or show "More fields", we will update you as soon as we are informed of any changes 👍

Juan Community Team at Wrike Wrike Product Manager Become a Wrike expert with Wrike Discover

Juan Wrike Team member Become a Wrike expert with Wrike Discover

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Folllowing List for Post: Custom Fields visibility frustrations in Custom Item Types
[this list is visible for admins and agents only]

Top
Didn’t find what you were looking for? Write new post