PUT requests timing out

I have a program that is running through a data table and doing a series of updates to Wrike via PUT requests.

The program works fine for the first two PUT requests but the third always times out. I've tried adding a 10 second wait between requests but that hasn't helped. 

0
6 comments
Spot On Innovative Approach Stellar Advice
Avatar
Stephen

We may need to take a closer look to see what's happening so I've raised a ticket for you David so we can investigate. Someone will be in touch soon.

Thanks!

0
Comment actions Permalink
Spot On Innovative Approach Stellar Advice
Avatar

I have the same problem with a serie of update via PUT requests

After two update with API Tasks (only for change title), the request hangs :

https://www.wrike.com/api/v4/tasks/xxxxxxxxxxxxx?title=E.2 - Phase exécution   <--OK

https://www.wrike.com/api/v4/tasks/yyyyyyyyyyyyy?title=E.2 - Phase exécution   <--OK

https://www.wrike.com/api/v4/tasks/zzzzzzzzzzzzz?title=E.2 - Phase exécution   <--Exception catch : Get Response is too long

 

0
Comment actions Permalink
Spot On Innovative Approach Stellar Advice
Avatar

For information, my request http timeout is 100 seconds

0
Comment actions Permalink
Spot On Innovative Approach Stellar Advice
Avatar
Hugh

Hey Eric!

Just raised a Support ticket for you, someone should be in contact with you soon!

0
Comment actions Permalink
Spot On Innovative Approach Stellar Advice
Avatar

Thank you Hugh,

I solved my problem. It was just a bug in my program.

I forgot the GetRepsonseStream 😱

 

0
Comment actions Permalink
Spot On Innovative Approach Stellar Advice
Avatar
Hugh

Glad to hear it Eric!

If you need anything else or have any more questions just let me know 😊

0
Comment actions Permalink

Folllowing List for Post: PUT requests timing out
[this list is visible for admins and agents only]

Didn’t find what you were looking for? Write new post