Problem with uri encoded special characters in call

I am trying to get multiple contacts back by id.  I know the syntax is contacts/{contactId},{contactId},

but the platform I am using, Power Automate, is encoding the commas before sending, so it looks like this
contacts/{contactId}%2C{contactId}.

It seems Wrike doesn't know what to do with the encoded comma and throws an error for invalid Id.

I have looked around and can't find a way to stop PA from encoding the url.  

Any thoughts?

Thanks,

Russ

 

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos
5 comments

Hey Russell Sprague, sorry for the late reply!

I've asked our Support team to reach out to you about this, and I can see they have 👍

Lisa Community Team at Wrike Wrike Product Manager Become a Wrike expert with Wrike Discover

Lisa Wrike Team member Become a Wrike expert with Wrike Discover

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

it would be good to put the resolutions in here from Support.

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Support's answer was they could not do anything about it and I should reach out to Microsoft.  So no resolution.

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Lisa  Can you open this up again with support?  I finally talked to Microsoft, and they told me the API calls endpoint should be able to support url encoded characters, and I should talk to the API developer.  So Circles.  Regardless of  who ever is responsible, it is causing me delays because I can't query groups of items that require sending comma delimited ID list in the url.

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Hi Russell Sprague, thank you for the follow-up. I've reopened a ticket with our Support Team so that they can provide you with an accurate reply 👍

Juan Community Team at Wrike Wrike Product Manager Become a Wrike expert with Wrike Discover

Juan Wrike Team member Become a Wrike expert with Wrike Discover

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Folllowing List for Post: Problem with uri encoded special characters in call
[this list is visible for admins and agents only]

Top
Didn’t find what you were looking for? Write new post