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Corriger les valeurs « N/A » et « Aucun résultat » dans les rapports avancés (Wrike Analyze)

Situation

Dans Wrike Analyze, les widgets peuvent parfois renvoyer des valeurs « N/A » ou s’afficher complètement vides. Cela signifie généralement qu’aucune donnée ne correspond à l’ensemble des filtres et des formules appliqués dans le widget. Cependant, il arrive que les filtres semblent corrects mais que les données attendues ne s’affichent pas. Les raisons les plus courantes sont le renommage d’objets dans Wrike (par exemple un projet) et le choix d’un tableau de données incorrect dans le rapport.

Important

Cet article traite uniquement des valeurs « N/A » et des widgets vides (pas des erreurs). Si votre rapport renvoie des erreurs, l’article Résoudre les erreurs dans les rapports avancés (Wrike Analyze) peut vous aider à les corriger.

Résolution de problèmes

Pour résoudre les problèmes de valeurs « N/A » ou de widgets vides dans Wrike Analyze, veuillez suivre les étapes suivantes :

  • Identifiez le filtre ou la dimension qui supprime toutes les données :
    • Dans les paramètres du widget, désactivez chaque filtre un par un pour vérifier si des données s’affichent. Commencez par les filtres du tableau de bord.
    • Si des données apparaissent après la désactivation d’un filtre spécifique, réactivez les autres un par un pour vous assurer qu’ils n’affectent pas le résultat.
    • Si la désactivation des filtres ne résout pas le problème, répétez les étapes pour les dimensions sous Lignes/Catégories.

Trois problèmes courants peuvent entraîner des valeurs « N/A ». Cliquez sur les encadrés ci-dessous pour découvrir comment identifier rapidement ces problèmes, les diagnostiquer et les corriger.

 

Les champs personnalisés

Cause possible

Les champs personnalisés sont stockés dans deux ensembles de tableaux de données : « Tâche » et « Dossier/Projet ». Le choix d’un tableau incorrect peut entraîner l’absence de données affichées ou des résultats inattendus.

 

Important

Ces types d’erreurs sont spécifiques aux champs personnalisés de type colonne/dimension. Vous pouvez en savoir plus sur leur utilisation dans la publication de la Communauté Personnaliser et analyser : résolvez l’énigme avec les champs en colonnes.

Solutions possibles

  • Identifier la table de données :
    • Les champs personnalisés sont stockés dans les tableaux de données « Tâche » et « Dossier/Projet ». Avec les tableaux de données standard, la différence est plus évidente (par ex., Nom du champ personnalisé de la tâche vs. Nom du champ personnalisé du dossier/projet). Les tableaux de données en colonnes stockent chaque champ personnalisé dans une colonne distincte, ce qui fait que le nom apparaît identique, quel que soit le tableau source.
    • Vérifiez la source du tableau de données. Pour ce faire, survolez la dimension afin de voir son emplacement :
    • Vérifiez si le champ personnalisé est renseigné dans des tâches ou des dossiers/projets.
  •  Supprimez et remplacez la dimension incorrecte :
    • Si le champ personnalisé est renseigné dans des tâches mais que la dimension issue de « Dossier/Projet – Champ personnalisé (Colonnes) » est utilisée, supprimez la dimension incorrecte du rapport.
    • Ajoutez de nouveau la bonne dimension provenant de la bonne table de données (par ex., Tâche – Champ personnalisé) dans le rapport.

 

Éléments renommés

Cause possible

Lorsqu’un élément est renommé dans Wrike, son titre est mis à jour dans les bases de données statistiques à chaque nouvel export de données. Cependant, si l’export de données actualise la base de données, il ne modifie pas les rapports existants. Si un élément renommé est déjà utilisé comme filtre, le « fantôme » de son ancien nom reste dans les paramètres du filtre. Par conséquent, la requête recherche l’ancien nom dans la base mise à jour et ne renvoie aucun résultat.

Ce problème survient le plus souvent avec le filtre « Inclure les données de », largement utilisé dans de nombreux rapports et qui affecte l’ensemble du jeu de données. Si l’espace utilisé comme filtre a été renommé, supprimé ou n’est plus partagé avec le lecteur, le rapport n’affichera aucune donnée.

 

Solution possible 

  • Si un filtre basé sur un élément ne renvoie aucun résultat, vérifiez l’existence de l’élément dans le navigateur de données. Pour ce faire, recherchez l’élément en utilisant exactement la même orthographe :
  • Si le navigateur de données ne renvoie aucun résultat, l’élément n’existe pas dans la base de données :
    • Vérifiez si l’élément existe toujours et s’il est partagé avec vous.
    • Vérifiez l’orthographe : l’élément a peut-être été renommé. Pour confirmer, copiez le nom de l’élément (p. ex. un dossier) et collez-le dans la barre de recherche du navigateur de données.
    • Si le copier-coller fonctionne, l’élément a été renommé, ce qui peut inclure de légères modifications telles que des changements de capitalisation.
  • Si l’élément a été renommé, mettez le filtre à jour en conséquence :
    • Sélectionnez la case supérieure pour inclure tous les éléments. L’indication filtrée en bas doit afficher « Inclure tout ».
    • Désélectionnez tous les éléments en cliquant de nouveau sur la case, puis sélectionnez spécifiquement la case à côté du nom de l’élément renommé.
    • Répétez ces étapes pour tous les autres éléments si les données semblent toujours incomplètes.

Tables de données incompatibles

Lorsque vous travaillez avec Wrike Analyze, il est important de vous assurer que les tables de données utilisées dans les filtres ou les paramètres de widget sont compatibles. Certaines tables de données, telles que « Projet » et « Dossier », n’interagissent pas comme prévu. Si des attributs liés aux projets et aux dossiers sont utilisés conjointement, le widget peut ne renvoyer aucun résultat. Pour résoudre ce problème, utilisez le filtre « Inclure les données de » pour l’élément parent afin d’afficher les relations parentales. Par exemple, pour afficher une relation parent-enfant entre un projet et un dossier, assurez-vous que le filtre est configuré pour l’élément parent.

Pour plus de détails sur la gestion des structures hiérarchiques dans Wrike Analyze, consultez cette publication : Dossiers et projets dans Wrike Analyze : structure hiérarchique.

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