Tous les articles

Résoudre les erreurs dans les rapports avancés (Wrike Analyze)

Situation

Wrike Analyze est un outil puissant pour créer des rapports avancés et visualiser les données. Cependant, vous pourriez rencontrer des erreurs courantes lors de l'utilisation des rapports de statistiques. Cet article va vous guider dans la résolution de ces erreurs pour corriger tous les problèmes avec vos rapports de statistiques.

Réponses d’erreur

Wrike Analyze affiche trois icônes d’erreur principales : Cône de signalisation, Loupe et Losange bleu. Cliquez sur les encadrés ci-dessous pour découvrir comment les identifier et les corriger rapidement.

 

Cône de signalisation

Cause possible

L’erreur « Quelque chose s’est mal passé » recouvre l’ensemble du rapport et le rend inaccessible. Ce problème indique souvent un dysfonctionnement lors de l’enregistrement du rapport.

Solutions possibles

  • Rafraîchissez complètement la page (hard refresh) et vérifiez si le rapport fonctionne.
  • Si le rapport s’affiche correctement, cliquez sur « Modifier » puis « Enregistrer » dans le coin supérieur droit.
  • Si le rapport devient vide (aucun widget dans le rapport), il peut être restauré à une version antérieure fonctionnelle. Dans ce cas, envoyez un ticket au Support en fournissant les informations suivantes :
    • L’heure approximative à laquelle le rapport fonctionnait pour la dernière fois et votre fuseau horaire.
    • Le lien interne du rapport concerné (copié depuis la barre d’adresse).
  •  

Loupe

Cause possible

La grande erreur jaune qui recouvre le rapport comporte généralement un message descriptif. Elle indique souvent qu’une dimension utilisée dans les filtres a été renommée. Le message d’erreur inclut la raison de l’échec.

Exemple

La dimension, Wrike Core (3109388). [Folder/Project Custom Field (Columns).Address Lat] est introuvable.

 

Solutions possibles

  • Déchiffrez le message pour comprendre l’erreur :

Exemple

Wrike Core — Nom du modèle de données.
(3109388) — ID du compte.
Folder/Project Custom Field (Columns) — Nom de la table de données.
Address Lat — Nom de la dimension.
Cette erreur indique que la requête n’a pas pu trouver la dimension nommée "Address Lat".

  • Cliquez sur l’icône en forme de croix en haut à droite du message d’erreur pour le fermer. Cette action rendra le rapport modifiable.
  • Si des dimensions utilisées dans les filtres ont peut-être été renommées :
    • Vérifiez les champs personnalisés mentionnés dans le message d’erreur qui sont utilisés comme dimensions dans le rapport.
    • Identifiez si des champs personnalisés ont été renommés / supprimés / retirés du partage avec tout le monde récemment.
    • Supprimez les anciennes dimensions du rapport.
    • En cas de renommage, ajoutez au rapport les dimensions portant les nouveaux noms.
    • En cas de retrait du partage, partagez le champ avec tout le monde et forcez le lancement de l’exportation des données dans le rapport. Si le champ ne peut pas être partagé avec tout le monde mais doit être utilisé dans le rapport, envoyez un ticket au Support en fournissant les informations suivantes :
      • Nom du champ.
      • Le lien interne du rapport (copié depuis la barre d’adresse) ou le nom du rapport.
      • Nom du widget concerné.
      • Une capture d’écran du problème, incluant tous les messages d’erreur ou icônes.
  • Après avoir effectué les modifications nécessaires, enregistrez le rapport.
  • Actualisez la page pour vous assurer que les changements ont été pris en compte et que l’erreur est résolue.

Losange bleu

Cause possible

Cette erreur peut se produire pour l’une des raisons suivantes :

  • une syntaxe de formule incorrecte
  • le renommage / retrait du partage / suppression des champs personnalisés utilisés comme dimensions dans le widget.

Solutions possibles

  • Passez le curseur sur l’icône d’erreur pour afficher les détails du message et identifier le problème. 

    Exemple

    Dans notre exemple, le problème concerne le champ personnalisé "Address Lat" ajouté à la base de données et utilisé comme filtre au niveau du tableau et comme filtre de widget. Par la suite, le champ personnalisé a été renommé "Address Latitude" et les tables de données ont été mises à jour avec succès, mais le rapport contient toujours l’ancien nom "Address Lat", ce qui provoque l’erreur.

  • Modifiez le rapport et cliquez sur l’icône en forme de crayon en haut à droite du widget concerné pour l’examiner.
  • Pour les erreurs de syntaxe dans les formules :
    • Passez en revue toutes les formules utilisées dans le widget.
    • Assurez-vous que la syntaxe est correcte et que toutes les dimensions et tous les champs personnalisés sont correctement référencés.
  • Si des dimensions ont peut-être été renommées :
    • Vérifiez les champs personnalisés mentionnés dans l’erreur qui sont utilisés comme dimensions dans le widget : filtres, formules, lignes, etc.
    • Identifiez si des champs personnalisés ont été renommés / supprimés / retirés du partage avec tout le monde récemment.
    • Supprimez les anciennes dimensions du rapport.
    • En cas de renommage, ajoutez au rapport les dimensions portant les nouveaux noms.
    • En cas de retrait du partage, partagez le champ avec tout le monde et forcez le lancement de l’exportation des données dans le rapport. Si le champ ne peut pas être partagé avec tout le monde mais doit être utilisé dans le rapport, envoyez un ticket au Support en fournissant les informations suivantes :
      • Nom du champ.
      • Le lien interne du rapport (copié depuis la barre d’adresse) ou le nom du rapport.
      • Nom du widget concerné.
      • Une capture d’écran du problème, incluant tous les messages d’erreur ou icônes.
    • Après avoir effectué les modifications nécessaires, enregistrez le rapport.
  • Actualisez la page pour vous assurer que les changements ont été pris en compte et que l’erreur est résolue. 

Note

S’il n’y a pas de message descriptif, le problème provient très probablement de la syntaxe de la formule ou de l’incompatibilité de certaines fonctionnalités. 

Haut