Delay when updating Task description

I am using task status to trigger Teams meeting creation through Power Automate.  I noticed that if I change the task description in Wrike, then change the status to trigger the Power Automate process, the description that is returned through my get Task API call is not correct, it is the previous version of the description.  It seems like there is a minute or so delay before the api will pull the correct description.  Is there a cache issue?  All the other task info comes back fine, it is just the description that is having issues.  I wonder if the autosave is slow?

Any help would be appreciated

 

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos
2 comentarios

Hi Russell Sprague, thank you for sharing your case with us. I see that you have mentioned this behavior in this thread and I've opened a ticket with our Support Team on your behalf so that they can investigate this and provide you with an accurate reply. You will be contacted shortly 👍

Thank you!

Juan Community Team at Wrike Wrike Product Manager Infórmate sobre las funciones y prácticas recomendadas de Wrike

Juan Wrike Team member Infórmate sobre las funciones y prácticas recomendadas de Wrike

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Russell Sprague yes, there is an up to 6min delay between what you see in the UI (which drives the trigger) and what is written into the DB (which is what the API fetches). This is not a bug but is by design (for reasons that I will omit here). 

Miron Mizrahi Community Team at Wrike Wrike Product Manager Infórmate sobre las funciones y prácticas recomendadas de Wrike

Miron Mizrahi Wrike Team member Infórmate sobre las funciones y prácticas recomendadas de Wrike

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Folllowing List for Post: Delay when updating Task description
[this list is visible for admins and agents only]

Arriba
Didn’t find what you were looking for? Write new post