Users Scope problems

I am having an issue with my api call to get user by ID.  It was working fine, but now it is saying it is out of scope

I am making the call from a Power Automate Custom Connection, and this is the call url I am using
https://www.wrike.com/api/v4/users/{userId}
and I am logged in using OAuth.  I am a Wrike admin on our account, so I should have access.  Like I said it was working fine in the past.

Any thoughts?  The documentation on Scopes doesn't really help.

Thanks

1
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos
3 commenti

Russell Sprague I've asked our Support team to reach out to you 👍

Lisa Community Team at Wrike Wrike Product Manager Become a Wrike expert with Wrike Discover

Lisa Wrike Team member Become a Wrike expert with Wrike Discover

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Lisa Thanks!

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Russell Sprague the /users endpoint requires a specific scope you will not have. Just use /contacts (https://developers.wrike.com/api/v4/contacts/)

Miron Mizrahi Community Team at Wrike Wrike Product Manager Conosci le straordinarie funzionalità di Wrike e le best practices

Miron Mizrahi Wrike Team member Conosci le straordinarie funzionalità di Wrike e le best practices

0
👍 Spot On 💡 Innovative Approach 💪 Stellar Advice ✅ Solved 🪄 Remove Kudos

Folllowing List for Post: Users Scope problems
[this list is visible for admins and agents only]

Su
Didn’t find what you were looking for? Write new post