API Access Denied to Certain Folders

Hello,

I've been working on an integration to keep our Salesforce and Wrike environment synced for changes as we have different departments who access Project-related work from different tools.

For the most part, this is working exactly as expected and 99% of the syncs work without issue, however periodically I get a Recipe error when attempting to update the Wrike Project, and attempting to process via Postman (https://www.wrike.com/api/v4/folders/{projectID}) nets me the same error:

"Folder not found or access denied error."

When I log in as our integration user (which is an Admin, and has all permissions), I have access to the Project/Folder, and can manipulate the Project manually.  I've also attempted to move the Project into a Space/Folder that's been made available to the entire team and still get this issue.

The Projects in question are fully marked complete and are being stored in a Folder that we have labeled as Archived, but there are no special permissions/limited access to the Folder.

Does anyone have an idea as to what I could look into in trying to identify what is causing these issues?

Thank you!

 - JD Lynn

0
1 commentaire
Spot On Innovative Approach Stellar Advice

Hi JD Lynn, welcome to the Community 🙌

I've asked our API experts to reach out to you about this, they will contact you ASAP. 

Let me know if you have any more questions or feedback about Wrike 👍

Lisa Community Team at Wrike Wrike Product Manager Become a Wrike expert with Wrike Discover

Lisa Wrike Team member Become a Wrike expert with Wrike Discover

0

Folllowing List for Post: API Access Denied to Certain Folders
[this list is visible for admins and agents only]

Haut de la page
Didn’t find what you were looking for? Write new post