Community

Welcome 🖖

Hi there! 🙂 Want to become a black belt Wrike Ninja? Here's how to earn a Wrike badge

Welcome 🖖 Have you checked out this week's Release Notes yet?

Hey! 👋 Curious about something? Visit How To to search and ask the Community for answers.

Welcome! 👋 Figured out a good tip or trick? Share it in Best Practices.

Want to connect your existing software to Wrike? Learn and ask how in the API section.

What can we help you with?

e.g. Gantt chart, Creating tasks, Sharing folders...

Email Forwards appearing as Tables

15 comments

  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Noel Howell

    *bumping up * happens to me too.

    Is this helpful? 1
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Stephanie Westbrook

    @Ben @Noel are these emails with HTML formatting?

    Stephanie Westbrook Community Team at Wrike 🌎Discover... Wrike Discover and become a Wrike expert. Click here to get started

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Noel Howell

    @Stephanie -- yes they are. I added one just now to test again.

     




    Is this helpful? 1
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Ben Silverstein

    @Stephanie, I can confirm that this is only HTML formatted emails on my end as well.

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Stephen

    Hi guys, thanks for testing. Our team is aware of the issue. I've raised Ben's original post to the Support Team so the team can be made aware of this post and I'll report back here once I know more 👍🔧

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Daniel Bosshard

    We have been struggling with the same issue.

    As a workaround, we have decided to create a new task in wrike and then copy/paste the content of the mail into the description.

    This works for us because of the following circumstances:

    • we all have dual monitors, so we can have our mail client on one screen and wrike on the other
    • we usually want only the relevant part of a long email chain in our task descriptions
    • we're spending some additional time with the task anyway, as we want the task title to be something other than the email's subject (and the description to include more than just the email's body)

    If circumstances are similar for you, I recommend this workaround. It's not perfect, but it won't cost you any significant amount of additional time compared to directly sending the mail to wrike.

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Stephen

    I can see the development team are currently investigating the issue. I've requested more information about when we should see this working as usual again.

    @Daniel, thank you for sharing this workaround to use for now 🙌

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Saadia Simon

    I've been experiencing this issue, and it's finally impacted a mission-critical part of our workflow so I dug as deep as I could on my own.

    The emails that were affected in my experience, were emails that had gone through sendgrid, which adds in some extra html markup in order to give it space to also insert a tracking pixel.

    It looks like wrike is tripping up on this markup - in my test cases it would then ignore html which is usually 'allowed' by wrike (as documented here: https://developers.wrike.com/documentation/api/datatypes/description), as well as ignore any line breaks, so the original email looks worse than even the plain text version.

    Can the development team look into either presenting the text/plain encoded version if the text/html encoded version will entail stripping some tags, or better yet tweak the parser to strip the table/tr/td/span html tags which as I said are just added in by sendgrid, and then process the rest of the email.

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Saadia Simon

    *Bump*

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Stephen

    Hi Saadia Simon, our development team has looked into this and you're somewhat correct, it is due to the HTML formatting that these tables are appearing. If you're sure there are no nested tables in the email (including your signature), then these tables should not appear in the Wrike task.

    Unfortautelty a fix for this in the description area will not be added to the short-term roadmap ahead of other essential updates. For now, a very manual workaround of copy and paste as plain text is the best route of action to take.

    I'll be sure to post back here when I have any new information.

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Saadia Simon

    Thanks for the response. There are nested tables, but they are added automatically by sendgrid, which powers a huge proportion of saas-generated emails and I'm certain affects a lot of wrike users, even if for most use-cases it's just a minor irritation (as it was for us, until now).

    The manual solution won't work for our use-case which involves generating dozens of emails automatically from our reporting system to create relevant tasks.

    I'm disappointed that this issue isn't being given higher priority (as a part of the general formatting options within the description field).

    Is this helpful? 1
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Mike Boysen

    Stephen,

    This basically makes your email integration worthless. Not going to fix it in the near term? I can't think of any other platform I've used that had this issue...for at least the past 10 years. We're fast approaching a year since this was reported and it's affecting me on a daily basis and making the content we put into wrike unreadable. I can't think of a simpler fix to address, especially something as visible to end users as this. 

    Sorry to be harsh, but there needs to be a development track separate from all the whiz bang features you're working on to address this sort of thing. I've never heard of teams releasing defective features and then moving on to the next feature. Seriously! Is there any testing going on before each release? Clearly the acceptance criteria are incomplete if there is. 

    There is pleasing users, and then there is just plain rigor and maturity in devops. 

    Is this helpful? 1
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Lisa

    @Mike Hey, jumping in for Stephen here. Thanks for bringing this up, I'll raise a ticket for you to keep the record and get back here when I have an update. 

    Lisa Community Team at Wrike 🌎Discover... Wrike Discover and become a Wrike expert. Click here to get started

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Mistyamber Reynolds

    We are also having this issue.  We have a trigger set up in Zendesk to create a task in Wrike when one of our agents' requests training on a ticket they come across.  For a while, we would get blank tables and the text from that trigger with the training details.  Now, we only get blank tables and none of the text is coming through.  This has put a complete stop to this process and does not notify management when an agent needs additional training.

    Is this helpful? 0
    Comment actions Permalink
  • Spot On! 👍 Innovative Approach 💡 Stellar Advice 💪
    Avatar
    Lisa

    @Mistyamber Hey, thanks for reaching out! I've raised a Support ticket for you, the team will be soon there to help!

    Lisa Community Team at Wrike 🌎Discover... Wrike Discover and become a Wrike expert. Click here to get started

    Is this helpful? 0
    Comment actions Permalink

Please sign in to leave a comment.

Folllowing List for Post: Email Forwards appearing as Tables
[this list is visible for admins and agents only]

Community

Welcome 🖖

Hi there! 🙂 Want to become a black belt Wrike Ninja? Here's how to earn a Wrike badge

Welcome 🖖 Have you checked out this week's Release Notes yet?

Hey! 👋 Curious about something? Visit How To to search and ask the Community for answers.

Welcome! 👋 Figured out a good tip or trick? Share it in Best Practices.

Want to connect your existing software to Wrike? Learn and ask how in the API section.